Home     |     .Net Programming    |     cSharp Home    |     Sql Server Home    |     Javascript / Client Side Development     |     Ajax Programming

Ruby on Rails Development     |     Perl Programming     |     C Programming Language     |     C++ Programming     |     IT Jobs

Python Programming Language     |     Laptop Suggestions?    |     TCL Scripting     |     Fortran Programming     |     Scheme Programming Language


 
 
Cervo Technologies
The Right Source to Outsource

MS Dynamics CRM 3.0

Asp.Net Programming

prompted for Id and password when opening .aspx pages


I can open a .NET 1.1 project fine but when I try and open a page within
that project I'm prompted for a username and password.

Any ideas on why I would be prompted for a username and password when trying
to open a  .aspx page?

I get the windows login screen:

Connect to 'Servername'

  Connecting to 'Servername'
  username

  password

"Tom" <whyamih@gmail.com> wrote in
news:uYq4poeoHHA.4400@TK2MSFTNGP03.phx.gbl:

> Any ideas on why I would be prompted for a username and password when
> trying to open a  .aspx page?

Your web.config or the site is probably configured to use Windows
authentication.

-----------------------------------------------Reply-----------------------------------------------
it is.
its only certain pages that this is happening on.

how can I fix it? My windows ID has the same access as all the other
developers working on the same web project and they aren't prompted for an
username or password when they open the same pages.

"Henrik Stidsen" <henrikstid@gmail.com> wrote in message

news:Xns993F923B34AE9hs235dk@130.225.247.90...

"Tom" <whyamih@gmail.com> wrote in
news:#w6GqFfoHHA.4772@TK2MSFTNGP05.phx.gbl:

> how can I fix it? My windows ID has the same access as all the other
> developers working on the same web project and they aren't prompted
> for an username or password when they open the same pages.

Just to be sure, you are using IE ?

Firefox and Opera etc does have some problems with Windows Authentication,
usually they show a login box.

-----------------------------------------------Reply-----------------------------------------------

I'm running IE 6.
I'm even getting the login box when I run the web site as well, either
through visual studio or IE (http://computername/website/) i get prompted.

its driving me nuts

"Henrik Stidsen" <henrikstid@gmail.com> wrote in message

news:Xns993F9FDEF4436hs235dk@130.225.247.90...

also, I'm not sure if this makes a difference or not, but I'm only prompted
for an username and password when I go to the 'design' tab of the web page.
I'm able to view the source, its only the design view I'm prompted. If I hit
cancel over and over again I can finaly see the design view of the page but
a lot of controls are missing for me to view.

"Henrik Stidsen" <henrikstid@gmail.com> wrote in message

news:Xns993F9FDEF4436hs235dk@130.225.247.90...

"Tom" <whyamih@gmail.com> wrote in
news:#g#30ffoHHA.4960@TK2MSFTNGP02.phx.gbl:

> also, I'm not sure if this makes a difference or not, but I'm only
> prompted for an username and password when I go to the 'design' tab of
> the web page. I'm able to view the source, its only the design view
> I'm prompted. If I hit cancel over and over again I can finaly see the
> design view of the page but a lot of controls are missing for me to
> view.

Youre prompted for username/password when wieving the page in design view
inside Visual Studio? If thats the case I would look at file permissions.

-----------------------------------------------Reply-----------------------------------------------
Ok i'll take a look at them.

"Henrik Stidsen" <henrikstid@gmail.com> wrote in message

news:Xns993FA5A78160Fhs235dk@130.225.247.90...

maybe some of the images (or other resources like javascript or css)
have ntfs security set differently, this can ocure if you moved your
files from somwhere else that the security descriptrors are also
copied, and you IIS requires credentials from you for this other
resources.

try re-setting all ntfs resources for your website

regards

On May 29, 4:27 pm, "Tom" <whyamih@gmail.com> wrote:

Add to del.icio.us | Digg this | Stumble it | Powered by Megasolutions Inc